Need help LPT tokens not transferring

My LPT in my Arbitrum One in my MetaMask wallet will not show up in Livepeer Explorer after my wallet connects so I can delegate them.

When you log in to MetaMask, are you sure you have chosen the Arbitrum network?

Have you added the LPT token address to your MetaMask? If not, you can click import tokens and enter: 0x289ba1701C2F088cf0faf8B3705246331cB8A839

Always make sure the contract address you’re adding is legitimate. You can double-check in Livepeer’s official docs:

My LPT tokens ARE on Arbiitrum in my MetaMask wallet. They just don’t transfer into Livepeer Explorer when I connect my wallet. It all worked find with the first batch of tokens, but this second batch does NOT show up in Livepeer Explorer.

Yes, I have repeatedly verified that I have chosen the Arbitrum Network in my MetaMask

Does MetaMask give you an error message? Are you staking to the same Orchestrator as the first time? If not Livepeer only allows one Orchestrator per ETH account. I haven’t had the issue the Livepeer Explorer, but I have in the had to restart my computer to get MetaMask to interact with contracts on Arbitrum.

Thanks for the suggestion.

I completely shutdown and restarted my computer. The LPT tokens in my MetaMask wallet on the Arbitrum One network will still not show up in Livepeer explorer when I open my Meta Mask wallet. Any more suggestions?

I seem to have the same problem now.

I send some ETH to my MetaMask on the eth network.
Then I send the eth to the arbitrum network.
After that I swapt the ETH to LPT via the link “Get LPT” on explorer.livepeer.org.

I can see my LPT on the Arbitrum network in the wallet, but I cant delegate them.

Edit:
Do I need to send the LPT to the contract address in this link maybe?

Edit 2:
In MetaMask it sais the right address when I press LPT - Token details:
“Token Contract Address: 0x289ba1701C2F088cf0faf8B3705246331cB8A839”

You need to connect your wallet (with the LPT in it) with the explorer. This is how it should look like:

Top left it should say “Arbitrum”, next to it is your connected wallet (0x52…cB0E in my case).

Yes, I’ve done all that.
It still sais “balance: 0”.

You can DM your address and I’ll take a look if you want

Seems like I just hade to wait, now they show up in explorer.livepeer.
Thanks for the help.

But it seems like the explorer have some problems. I delegated the LPT but they still show up in my balance on explorer (not in metamask).