Withdraw with Metamask/NanoS shows 0

Can you explain exactly how I am to withdraw my LPT?
I must be misunderstanding something fundamental because metamask is showing “0” when I click “Withdraw”.

See attached image “20210110_WithdrawExplorerMetamask.png”

  • Using explorer.livepeer.org on Mac Chrome with Metamask and my NanoS
  • I staked funds a couple years ago… all was well
  • Over 7 days ago, I successfully unstaked everything and now see “WITHDRAW -144LPT”
  • I click “WITHDRAW” and metamask shows Withdraw Stake 0. I can’t edit the amount.
  • I tried “Confirm” and get an error (transaction with 0 ETH)

Also, I understand this should restore the funds to the address I originally staked from (my wallet). But Metamask is showing From: (my wallet address) > To: (some other address I’ve never seen).
Shouldn’t this just drop the LPT to my NanoS wallet?

Thanks.
Bob

I believe the “Amount” field in metamask is referencing the amount of ETH you are sending as part of the transaction, which is correctly labeled as zero. I don’t believe the metamask window would have any context to show the result of the LPT transfer as part of the transaction. Have you tried confirming the txn and seeing the token appear back in your wallet?

Hi Dob,
Thanks for your reply. Yes, I tried “Confirm” and get an error (transaction with 0 ETH).

Also, can you advise if the receiving address is supposed to be unknown to me?

Thanks.
Bob

Yes, the receiving address of this transaction is the Livepeer Protocol bonding manager contract, which will then transfer the token to you.

As for the error, a couple quick checks - is your ledger plugged in and unlocked? Is it connected through your metamask account? Copying @ads1018 into this conversation, who may have more insights into debugging the ledger/metamask part.

Yes, NanoS is unlocked and in the “Ethereum” app. Metamask says it’s connected (green dot upper left). Metamask correctly shows the ETH balance in that wallet. When I click “Confirm” in Metamask, it instantly flashes the error and then closes. (Nothing registers on the NanoS.)
Thanks.

Mystery solved. I hovered over the “Failed” in Metamask and it showed the real issue “Error: TransportStatusError: LedgerDevice: Invalid data received: (0x6a80)”… I googled this and discovered I had to reenable “Contract Data Allowed” on the NanoS Ethereum app… Whew.

Thanks for being a sounding board. This ticket can be closed.

Glad you were able to solve it!